Support Center

Why are Internet Explorer 6 and 7 no longer supported?

The new Doodle requires Internet Explorer 8 or above. Internet Explorer 6 and 7 are very old and insecure Browsers. We highly recommend to upgrade Internet Explorer 6 and 7 to a new version. You can download the latest Internet Explorer from here. If you are not allowed to upgrade you will be shown a very basic version of Doodle as a fallback.

Contact Us

support@doodle.com
http://assets3.desk.com/
false
doodletweet
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete